Readers of our mini-PC reviews would have noticed that our routine involves detailed power consumption tests. Ensuring a level playing field for all the units involves turning off automatic Windows updates (so that we don't have unnecessary processes taking up CPU cycles or downloading of updates consuming network bandwidth and driving up the idle power consumption). On Windows 8.1 and earlier versions, turning off automatic updates was trivial, but Windows 10 presents some challenges.

Our review of the ECS LIVA Core (published yesterday) was the first to make use of Windows 10. Turning off updates in Windows 10 Professional is not too difficult using the Group Policy editor, but Windows 10 Home has only one way to prevent updates from getting downloaded - by setting the network interface as a metered connection. (Update: It is also possible to turn off the Windows Update Service itself in Windows 10 Home) After having configured the WLAN connection on the ECS LIVA Core to be metered, we set about running our benchmarks.

Testing out Netflix streaming is a part of our evaluation of the HTPC credentials of a system. Firing up our test stream in the Windows 10 Netflix app and bringing up the debug information gave us a nasty shock. Despite being on a 75 Mbps Internet connection, the app was streaming the test title at a measly 235 kbps. Trying to manually set a higher buffering bitrate in the Stream Manager (accessible via Ctrl-Shift-Alt-S) ended up force-quitting the app without any warning.

Windows 10 Netflix App

I immediately searched online and found a Reddit thread dealing with a similar issue. Initially, I thought that the Netflix app was buggy (as a previous version on another Windows 10 PC was able to stream at the maximum bitrate without any issues). In order to rule out the PC's WLAN connection as the culprit, I fired up Microsoft Edge and streamed the test title using the HTML 5 interface for Netflix.

Windows 10 - Microsoft Edge - Netflix HTML 5 Streaming

The title streamed with the maximum video bitrate (similar to the app), but the audio was only 2.0 at 96 kbps (no Dolby Digital Plus 5.1 stream at 192 kbps).

A few days after finishing up the benchmarking, the OS threw up a message indicating that it had been a long time since it had been able to check for updates. That is when it struck me that the metered connection could have been the culprit for the behavior of the Netflix app. I immediately tested out with the network connection set to metered and also with the setting at default (non-metered)

As I had guessed, the metered connection indeed turned out to be the issue. I also confirmed that the metered connection setting had no effect on the HTML 5 streaming case using Microsoft Edge.

All in all, the PSA here is that if one sets the network connection to metered for any purpose, make sure to turn it off if Netflix streaming at the highest bitrate is required through the Windows 10 app.

Comments Locked


View All Comments

  • barleyguy - Thursday, October 8, 2015 - link

    "but Windows 10 Home has only one way to prevent updates from getting downloaded"

    Can't you also just disable the Windows Update service in services? It seems like that would work better with less side effects. (I'm actually planning to do that on my Windows 10 laptop.)
  • ganeshts - Thursday, October 8, 2015 - link

    Yes, looks like that is also a possible option. I have updated the piece with a link to that.
  • blaktron - Friday, October 9, 2015 - link

    You would be MUCH better off using a firewall rule to block it from checking. Turning off the service can have other effects compared to just turning off updates on Windows 8.

    Basically you need the same solution for both platforms or the data is effectively meaningless.
  • coolhardware - Thursday, October 8, 2015 - link

    Seems like a reasonable solution :-)
  • Shadowmaster625 - Thursday, October 8, 2015 - link

    On my crappy windows tablet, I had disabled windows update service for several months. When I renabled it, I had 80 updates. It got caught in an endless update-crash-restart loop and that was basically the end of that pos. Microsoft garbage at its finest.
  • Swiftnc - Thursday, October 8, 2015 - link

    Likely the virus/rootkit you got because you disabled updates that is interfering with the update process once you enabled it again.
  • barleyguy - Thursday, October 8, 2015 - link

    Stopping windows update service does not prevent security updates on Windows 10. They come in through a different mechanism. (According to the Windows 10 review on this site.)
  • Samus - Friday, October 9, 2015 - link

    I agree with Microsofts' update model for Windows 10. For the most part, Home users that have historically disabled/not installed updates to Windows were the most vulnerable and infection-prone. Why would your everyday user NOT want Windows updates?

    It's hilarious to say you don't want (free) ongoing product improvements. Very few updates over the last decade have caused problems for end-users. Risky updates are almost always categorized as Optional (such as CPU microcode updates or modifications to how Windows interacts with certain software or drivers) and these are not installed unless you go out of your way to specify them.
  • Steko - Friday, October 9, 2015 - link

    So I disabled auto-updates in W8 for several years because they got rid of the feature that let you delay reboots indefinitely. So instead W8 would just automatically reboot with one 15 min notice which I found to be 100% unacceptable for a machine I primarily own for coop gaming. Maybe they've fixed it since then but I don't care I manually update once a week and if I get owned because of this so be it.
  • inighthawki - Friday, October 9, 2015 - link

    I would hardly call it "one 15 minute notice" - They give you three days and it tells you every day how many days you have before that (at least it has a mention of it on the login screen, but I swore it also told you at the desktop at least once a day in advance as well).

    That said - I do not disagree with your reaction. I too would just set the updates to "Notify but don't install" and then do it at my convenience and reboot immediately when I had the chance.

Log in

Don't have an account? Sign up now